top of page

Questions and Answers

Public·25 members

Oracle 10g For Mac Os X



If you set up NFS, then you can download and unzip Oracle on the Mac, into a directory you share using NFS(www.oracle.com, Downloads, look for Database 10g for Linux, 32 bit).3 While it's downloading, it might be a good time to install your favourite Firefox bookmark synchronisation service - I use Foxmarks. Then within CentOS you can simply cd to that directory and execute ./runInstaller.Otherwise, you'll have to download Oracle from inside CentOS.You might as well also download the Oracle Database 10g Companion CD while you're at it (672 MB) if you are going to want to install Application Express later.




Oracle 10g For Mac Os X


DOWNLOAD: https://www.google.com/url?q=https%3A%2F%2Ftinourl.com%2F2ucEH3&sa=D&sntz=1&usg=AOvVaw3MEgyAyOwTkGDVFRydQGTe



Although the server process is started by default when you create the database, it will need to be restarted any time you restart the database.Enter the following command in CentOS, as the oracle user:


Download from www.oracle.com/technology/products/database/sql_developer.A ready-to-run Mac OSX binary is provided (SQLDeveloper.app). I must admit I was expecting some clunky Windows Java port, but I was pleasantly surprised.The Preferences are in the wrong place, but apart from that it's looking a lot like a real Mac application. Nice job, guys!More resources are available on the official SQL Developer mini-site.I won't repeat the "Getting Started" instructions here, as it's just a case of clicking on the icon.


There is some debate about how suitable this is for small installations where all this /u01/app/oracle/product business is somewhat redundant.Perhaps I'm missing something as I'm not a DBA, but I prefer something like this:


However, by this point I'd already defined the database home as /oracle/10g when installing the database, so I put the new home at/oracle/10g_http. It's not really ideal and now it's hard to change, as the installer hardcodes it in a large number of config files. Damn.


I have searched high and low and can't seem to find any download for Oracle Database 10/11g for Mac OSX. There area pages with links, but all the links are dead or point to the standard oracle downloads with no OSX version.


I know it works OK without doing this, but for consistency across users and groups, you should include a line like:sudo dscl . -append /Groups/dba GroupMembership oracleafter creating the dba group and the oracle user.This way:dscl . -list /Groups GroupMembership grep dbawill show the members of the dba group.


!. tried to install oracle software with out database. It installed successfully but when tried to create database with dbca.I put all information but in the database creation windows it againshowed the same error. Error ORA-12547 TNS lost contact Error.


oludotun-ogunyades-computer:bin oracle$ otool -hv lsnrctllsnrctl:Mach header magic cputype cpusubtype caps filetype ncmds sizeofcmds flagsMH_MAGIC_64 X86_64 ALL LIB64 EXECUTE 13 1864 NOUNDEFS DYLDLINK TWOLEVEL


@MT: I would imagine you failed to create a home directory for oracle user (/Users/oracle in my example) or mistyped it when creating oracle user. Are you actually able to become an oracle user even with this error?


Alex, thanks a lot for the post!I have installed Oracle 10g following your instructions. Unfortunately, once the installation was complete I was not able to start Oracle. When I enter sqlplus commands get this:-bash: sqlplus: command not foundThere is sqlplus folder in /Volumes/HD/oracle/oraInventory. Somehow I have 2 oraInventory folders: users/oracle/oraInventory and /Volumes/HD/oracle/oraInventory.Can you please help me to fix this problem?


Sir, i tried my best to install oracle 10g on mac os x 10.7.3 LION, but at max i can install the software only, i have a database installed on vm-ware fusion on win-7. So, is there any way to copy that database from there, and yes i tried to create database manually, but when creating password file for sys i am getting segmentation fault-11, and i am unable to start sqlplus.. Same error of segmentation fault.any solution will be highly appreciated.Thank you sir.


Sir, thanks for your support, finally i got what i wanted. I have installed win-xp on vmware fusion, and then oracle database on xp. Now i can work on SQLDeveloper, eclipse java IDE, isql*plus on mac only.


*General Note: As the creators suggest Oracle XE should be used for testing purposes only. Also the majority of passwords on the VM have been setup by default to oracle and should be changed for obvious security reasons.


Hello Dipika, i encountered this error as well. I am running 19c. When you start your oracle database on the virtual machine, it gives you some database information. Please check to see what those credentials are, they may be different from what was used above. Check specifically for these:


What is throwing me off is your example to test using SQL and using the hr username and oracle password, is this simply a sample database? How do I set up my own database on my Mac to do my coursework?


Would it be possible to create a step by step guide on installing oracle directly on ubuntu (since running on vm is a bit slow if your machine is a bit obsolete)? There are a few articles on the internet but I failed each time I tried implementing the process.


I have been trying to download Oracle Database 11g release 2 for mac os but in the given link by oracle I can only see Linux x86 and Linux x86-64. Is this ok to use this Linux file for installing oracle database in mac


user@user-mac .emcli % cat .emcli.logAug 29, 2021 7:07:51 PM oracle.sysman.emCLI.verb.SetupVerb executeSEVERE:java.io.IOException: java.lang.ClassNotFoundException: sun/nio/fs/LinuxFileSystemProviderat oracle.sysman.emCLI.omsbrowser.OMSBrowser.getConnection(OMSBrowser.java:727)at oracle.sysman.emCLI.omsbrowser.OMSBrowser.getPageInternal(OMSBrowser.java:920)at oracle.sysman.emCLI.omsbrowser.OMSBrowser.getPageCommon(OMSBrowser.java:858)at oracle.sysman.emCLI.omsbrowser.OMSBrowser.getPage(OMSBrowser.java:803)at oracle.sysman.emCLI.verb.LogoutVerb.doLogout(LogoutVerb.java:268)at oracle.sysman.emCLI.verb.SetupVerb.execute(SetupVerb.java:819)at oracle.sysman.emSDK.emCLI.CLIController.execute(CLIController.java:367)at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)at java.lang.reflect.Method.invoke(Method.java:498)at oracle.sysman.emCLI.StandAloneLaunchHandler.invoke(StandAloneLaunchHandler.java:413)at oracle.sysman.emCLI.StandAloneLaunchHandler.launch(StandAloneLaunchHandler.java:286)at oracle.sysman.emSDK.emCLI.CLIController.launch(CLIController.java:255)at oracle.sysman.emSDK.emCLI.CLIController.main(CLIController.java:207)


Correct me if I am wrong but I think Oracle has now come out with 10gR2 that will run native on the Intel macs. If this is really what I think it is I am going to be really excited. I found it while looking for oracle to install on my tower that I just set up at home as a server.


About

Welcome to the group! You can connect with other members, ge...

Members